Search found 36 matches

by efalstrem
Mon Jul 05, 2010 6:52 pm
Forum: MacGregor Powersailor Discussion
Topic: Velcro sail ties
Replies: 2
Views: 1026

Velcro sail ties

Does anyone know where I can buy some velcro sail ties/straps?
by efalstrem
Mon May 31, 2010 8:44 pm
Forum: MacGregor Powersailor Discussion
Topic: Raymarine S1 Autopilot
Replies: 8
Views: 1509

Re: Raymarine S1 Autopilot

After spending an enjoyable, albeit wet, weekend at a nearby marina. After being uinderway for about a half hour I decided to try the autopilot again. You guessed it! It worked and worked a treat the remainder of my three hour trip home. The only thing I think I did differently was to engage the clu...
by efalstrem
Sun May 30, 2010 8:44 pm
Forum: MacGregor Powersailor Discussion
Topic: Raymarine S1 Autopilot
Replies: 8
Views: 1509

Raymarine S1 Autopilot

I set out on my first trip away from my mooring this year last Friday. Once clear of the marina I went to engage the autopilot and nothing happened. After a few attempts I gave up trying. Upon arrival at my destination I pulled out the manual. The first alongside trial listed is to go from standby t...
by efalstrem
Sun May 16, 2010 6:35 pm
Forum: MacGregor Powersailor Discussion
Topic: Installation of Canopy
Replies: 5
Views: 1051

Re: Installation of Canopy

Dodger - That's the word I was trying remember! At 73 (today is my birthday) I have an excuse for forgetting. The model is the wide one. Any further help/photos, etc. would be much appreciated.
by efalstrem
Sat May 15, 2010 9:09 pm
Forum: MacGregor Powersailor Discussion
Topic: Installation of Canopy
Replies: 5
Views: 1051

Re: Installation of Canopy

No, I mean the canopy that goes over the hatch. Maybe 'm not using the right terminology.
by efalstrem
Sat May 15, 2010 8:38 pm
Forum: MacGregor Powersailor Discussion
Topic: Installation of Canopy
Replies: 5
Views: 1051

Installation of Canopy

My 2002 :macx: came with a brand new factory manufactured canopy when I bought the boat two years but I had never bothered to try installing it until today. With the help of a very seasoned sailor friend we tried to figure out how to put it together. After a frustrating hour of trying we gave up. Ha...
by efalstrem
Fri Sep 04, 2009 9:04 pm
Forum: Destinations, Clubs, Events and Venues
Topic: Comox, Campbell River, Parksville?
Replies: 2
Views: 776

Re: Comox, Campbell River, Parksville?

I live in Campbell River, have a 2002 MacGregor 26X moored at Pacific Playgrounds. You are welcome to have a look.
by efalstrem
Thu May 21, 2009 11:34 pm
Forum: MacGregor Powersailor Discussion
Topic: Best weight distribution?
Replies: 12
Views: 1506

Re: Best weight distribution?

On Saturday I flushed my water tank which is built in right forward of the gallley on the port side. I think it holds about 15 gallons. I also have a full 25 litre gas tank stored in the port storage aft in the cockpit. I noticed tonight that the boat has about a five degree list to port. Does anybo...
by efalstrem
Sat May 16, 2009 9:24 pm
Forum: MacGregor Powersailor Discussion
Topic: Honda 50 HP problem
Replies: 46
Views: 8235

Re: Honda 50 HP problem

Again, thanks for the comments, Ray. This morning I went down to the boat to move it to my assigned berth. It wasn't very far to go but before setting off I paused and took several minutes to plan my short passage. I checked the throtle control ahead and astern gently before letting go the lines. I ...
by efalstrem
Fri May 15, 2009 10:37 pm
Forum: MacGregor Powersailor Discussion
Topic: Honda 50 HP problem
Replies: 46
Views: 8235

Re: Honda 50 HP problem

Your point is very well taken and I do agree with you wholeheartedly. I don't mind being singled out if it will remind others in the boating community to learn from my failure to properly prepare for this event. It was foolish of me not to review in my mind "what if" scenarios but it seemed such a s...
by efalstrem
Thu May 14, 2009 11:38 pm
Forum: MacGregor Powersailor Discussion
Topic: Honda 50 HP problem
Replies: 46
Views: 8235

Re: Honda 50 HP problem

Hi All: My mechanic inspected my motor and throttle cables today and the problem was pretty much exactly as described by Kayakdan. The outer wire had cracked and the cable had stuck in the wide open position. He tells me the cable run was poorly done and will be making some changes when he installs ...
by efalstrem
Wed May 13, 2009 11:56 pm
Forum: MacGregor Powersailor Discussion
Topic: Honda 50 HP problem
Replies: 46
Views: 8235

Honda 50 HP problem

Boy, did I ever have an exciting few minutes this evening! Today was the day to put my 2002 :macx: in the water. The mechanic had just finished installing a completly new steering system(cable, bezel, et al). An hour before towing the boat to the marina he came and checked over my four stroke 2005 H...
by efalstrem
Tue Apr 14, 2009 7:25 pm
Forum: MacGregor Powersailor Discussion
Topic: Loose steering on 26X
Replies: 15
Views: 1921

Re: Loose steering on 26X

Darry: I had a tech check out my steering today and he tells me that the current setup is far too stiff. He has lubricated the cable but tells me that it will need to be replaced if I ever hope to complete the installation of the S1 Autopilot. Have you fitted your Uflux Racktech kit yet? Was the 10'...
by efalstrem
Sun Apr 12, 2009 4:38 pm
Forum: Repairs and Modifications
Topic: Raymarine S1 Wheel Pilot installation photos *many photos*
Replies: 85
Views: 11613

Re: Raymarine S1 Wheel Pilot rudder indicator installation

I have just started to install my S1 autopilot in my 2002 :macx: . I can't figure out how to fit the rudder indicator. My Honda 50 hp outboard and all its associated linkage for steering is external in the motor well. All the photos shown on this forum seem to be for internal linkage. Can anyone ple...
by efalstrem
Wed Mar 04, 2009 10:08 pm
Forum: Repairs and Modifications
Topic: Raymarine S1 Wheel Pilot installation photos *many photos*
Replies: 85
Views: 11613

Re: Raymarine S1 Wheel Pilot installation photos *many photos*

I received my S1 autopilot yesterday and now read DaveB'c comments about the AP not beibg suitable for an :macx: Are there any other :macx: owners out there who have successfully installed the S1? Do you really need a 20" wheel? Also, does the rudder indicator have to be installed to make the AP work?